Simon 2.4 requires Tiger or later

One of my customers alerted me this morning that the just-released version 2.4 of Simon no longer works on Mac OS X 10.3.9 (Panther). I keep an old clamshell iBook on 10.3.9 for testing purposes, and just confirmed that this was the case. It seems that the framework used for the new Calendar plug-in, which caused hassles when building, also precludes running on 10.3.9. Even removing the framework and the plug-in from the built app didn't help.

I have been planning on dropping 10.3.9 support sometime this year anyway, but have been delaying that as long as possible. It no longer seems possible... so version 2.4 now officially requires a minimum of Tiger, i.e. Mac OS X 10.4 or later. (It works great on Leopard, too.)

I apologize for any inconvenience this may cause. I have updated the Simon site, release notes, and software listings accordingly. I've also added a link to Simon 2.3.5, the last 10.3.9-compatible release, on the Simon site.

If you are still using Mac OS X 10.3.9, I really recommend upgrading to 10.4 or 10.5. Tiger and Leopard include many great enhancements, and almost all software nowadays requires at least 10.4, and more and more are requiring 10.5.