Caboodle 1.4b3 released

Here's a second third beta release of Caboodle 1.4.

This release includes fixes for Mac OS X 10.7 (Lion) compatibility.

Update: Added full screen support on Lion as well!

It also restores PPC support, which was accidentally omitted from the first beta. It's an ongoing struggle to maintain PPC support in my apps; Apple is trying hard to eliminate it. Which brings me to an important point: I've decided that to be able to move to the new Xcode 4 development tools, and leverage some of the great new stuff in Lion, this version (and any 1.4.x bug fix releases) will be the last to support PowerPC (PPC) and Mac OS X 10.5. Version 1.5 will require an Intel-based Mac and Mac OS X 10.6 (Snow Leopard) or later.

Considering only about 3% of the Caboodle userbase are still on PPC machines (and most of them on Tiger), hopefully this won't be too inconvenient; those people can continue to use version 1.4 until they're ready to upgrade (or 1.3.7 if they are still on Tiger). As for Leopard, that's currently about 12% of the Caboodle userbase currently, but I expect it'll decline by the time 1.5 is out.

It's always difficult to drop support for old OS versions or machines, but it's a necessary part of software development, especially when Apple keeps pushing things forward and dropping support for older technologies in their development tools. Time marches on!

Download Caboodle 1.4b3 now!