Simon 3.6.3 released

A quick fix to version 3:

  • Fixed an issue that prevented the password preference from being used under OS versions before Yosemite.

As I said in my previous post, if you're using OS X 10.10 (Yosemite), I recommend that you upgrade to version 4, if you haven't already. It includes heaps of great improvements. But if you're on 10.6 (Snow Leopard) to 10.9 (Mavericks), I recommend that you download Simon 3.6.3 now.

Re: Simon 3.6.3 released

Simon 3.6.3 has the same problem as 3.6.2 for me (running under 10.6.8): editing notifiers does not work.

When I click on the edit icon, it highlights for a moment, but the editor window does not open. No such a problem with 3.6.1.

David Sinclair's picture

Re: Simon 3.6.3 released

Fixed in 3.6.4.