Simon icon Simon
Flexible server monitoring

FTP upload problem.. no feedback no work?

I'm trying to upload to an FTP server on a shared host (lunarpages). I can't get it to work and I think, repeated failures caused my shared host to black list my IP address!

I've had the IP unblocked by Lunarpages but I still can't get upload to work and simon is a little silent at the problem. I can wipe the password field and it still appears to work and gives no error message.

I know Cyberduck works with the same credentials and I'm pretty sure I've got the paths right. Any way to see what's failing where?

David Sinclair's picture

Re: FTP upload problem.. no feedback no work?

Are you referring to uploading a report via the "Upload to Remote" report kind? If so, it's just a matter of entering the correct host, username, password, and path. Don't forget to include the "public_html" or equivalent if you're using the main FTP account, or omit it if you're using an account that goes directly to a page. Try omitting the path to see if that helps (it might upload to a different location than you expect).

I've searched and can't find

I've searched and can't find the files. Is there any way to see the FTP transaction text?

David Sinclair's picture

Re: I've searched and can't find

You could look in the Console (in /Applications/Utilities) to see if any errors are logged there.

FTP not working

I was looking here for a hint because I've never been able to get it to upload. I FTP many times a day to my site using Transmit, but Simon has never worked. I tried this idea of removing the path, but Simon insists on having something there - it just doesn't make any sense to me, and I really don't have time to run packet traces. FTP is, usually pretty straight forward, name, path pw there you are, but it doesn't do it, and there's no feedback, or error. Simon acts as if it worked.

David Sinclair's picture

Re: FTP not working

Hi, sorry for the delay in replying.

Could you email me screenshots of your report setup, and provide me with the host, username and password so I can try it myself in the debugging environment (create a new sub-account if desired).

David Sinclair's picture

Re: FTP not working

Another reply: I have added a special debug mode to the FTP helper used when uploading reports, that will hopefully assist in diagnosing the problem.

This is in Simon version 2.4.2, which I've just released:

  • Added a hidden preference to output debug information from the helper for the Upload to Remote Server report plug-in. It can be activated by entering "defaults write com.dejal.simon2 RemoteWebDebugMode YES" in Terminal.

Please download it and give that a try.

FTP

thanks for the suggestions, David - I'll give them a try in the next few days - i'm going to create another thread about another thing I hope to get a hint on - Thanks again for your great work, and support.