Simon icon Simon
Flexible server monitoring

Notifications not working - at all!

I'm on 10.5.7 and although Simon reports notifications were sent, they actually don't get sent. I have SMS and e-mail notifications set up. Tested the SMS settings by manually sending an e-mail (Apple Mail), and worked fine. Also didn't receive an e-mail (checked junk and spam folders).

David Sinclair's picture

Re: Notifications not working - at all!

The notifiers do work, though can sometimes be tricky to configure.

The Simon FAQ has items to help, including:

I read the FAQ already. I

I read the FAQ already. I got e-mail working fine, but SMS is absolutely not working. Using the same info in Apple Mail (e-mail address, subject, body), I can send texts fine, but both the SMS plugin, and the e-mail plugin won't send a text to

David Sinclair's picture

Re: I read the FAQ already.

What settings are you using with the Email notifier? If you're using the Automatic transport successfully, it should work with the SMS plugin (just make sure you enter a valid From address).

If you're using a custom SMTP server config, though, that option isn't available for the SMS plugin. The SMS plugin only works with SMTP servers that don't require authentication.

So your options are:

  1. Use a different email address with the SMS plugin; one that doesn't require authentication.
  2. Use the Email notifier to send SMS — just enter your email address.
  3. Use the Clickatell service with the SMS plugin (which charges a small fee per message).

Hope this helps.

I tried those already! I am

I tried those already!

I am using the automatic transport (that's working for e-mails), with the SAME from address I use for e-mails, and it's not working. Also tried to use an e-mail notifier to send SMS, no SMS was sent (same settings as regular e-mail notifier that does work, but with

Don't really want to pay for Clickatell, when the e-mail method should work!

David Sinclair's picture

Re: I tried those already!

Sorry to hear that. Getting it working in the Email notifier would be key to getting it working in the SMS plugin, since they use basically the same code.

Perhaps you could email me screenshots of your SMS and Email notifier configurations for SMS, in case I can spot something.

Having the same issue

I'm having the same issue, unable to send out SMS. Or, at least, not receiving them.

I've even set up an email notifier, putting the txt address in the TO and my email address in the CC. I got the email, but no text message.

UPDATE: Initial testing was on a Snow Leopard MBP, but moved it to a Leopard Mac Mini. Having the same issues with notices. SMS never works. I created a PHP page that will send me a text message and it works every time I hit the page, but Simon only hits it periodically.

This is a serious issue as these notices are needed; otherwise Simon has little use as a monitoring tool.

This is the Enterprise version.

David Sinclair's picture

Re: Having the same issue

I'm sorry to hear that.

Very strange that you go the same message via email but not SMS... that might suggest the wrong email address, or an issue with the phone provider, though those don't seem entirely likely.

Perhaps try reversing it — put your email address in the To: and the text message address in the CC:, and see if that makes a difference.

You can certainly invoke your PHP page as a notifier as a workaround, though I'd like to help you solve the problem.

Note that there is a known issue with the SMS plugin under Snow Leopard, where the Edit Notifier window can become unresponsive when you choose SMS. We've already fixed that issue, and will be releasing an update soon. I can send you a build if you want to try that.

More info

I've been trying to get Simon to send out SMS messages on 2 different computers and they will not go. I've tried the following:

None of them worked. I also tried putting my txt address into the TO: and CC: fields of the email alert. I've tried it with another email (either in the TO or CC field) and by itself. None of the tests sends out a text message to my phone, though I will get an email if I included an email address.

Simon will hit the PHP page I've set up and that sends out a text msg to my phone, which is how I check to make sure that I'm getting texts to the phone.

The computers are:
- MBP, Intel, running 10.6.2
- Mac Mini, Intel, running 10.5.8


David Sinclair's picture

Re: More info

Is this with the Email plugin?

If so, try entering these commands in Terminal to enable extra debug logging, and to use the recipient instead of the sender's mail server, and see if either helps:

defaults write com.dejal.simon2 EmailDebugMode YES
defaults write com.dejal.simon2 EmailUseRecipientServer YES

If not, please send the log info to me for further analysis.

[Responses may be slow till next week; I brought a cold back from my trip to DC, so I'm recuperating in bed.]