Simon icon Simon
Flexible server monitoring

SMS Notifier / Recipient not accepted

Hi Folks -

I was very excited to see the addition of the SMS notifier in Simon -- awesome!

When trying to set up the E-mail SMS notifier, however, I'm running into a problem. I can email my personal phone number (say it's 999-999-9999) from Mail.app to

9999999999@txt.att.net
or
9999999999@mms.att.net

And everything comes through fine. I have three e-mail addresses configured (with their appropriate SMTP servers) in Mail.app. All of them work.

When I try, with any of those 3 email addresses, to send an SMS from Simon, however, the following shows up in the logs:

3/25/10 9:25:47 AM Simon[70060] Recipient not accepted by server:
550 5.7.1 <9999999999@mms.att.net>: Relay access denied

Does anyone have any hints on how I can coax Simon into sending along the same kinds of information that makes the message from Mail.app acceptable vs. the apparently unacceptable one from Simon?

Thanks a lot for those of you who created this plugin -- solves a huge problem for me :)

--Matt

David Sinclair's picture

Re: SMS Notifier / Recipient not accepted

Firstly, sorry for the delay in replying. As mentioned in the site-wide alert this week, I've been on vacation without internet access.

Try using the Email plugin, using the same settings as in Mail, and see if that works. There are some subtle differences in the mail handling code between the SMS and Email plugins, so it might work better there. Please let me know whether or not that helps; there are a couple of other things we can try if not.

You can thank Daniel Ellis for the SMS plugin.

Re: SMS Notifier / Recipient not accepted

Thanks David --- no worries about being away...

I tried the Email plugin with the same result... I made sure that the "From" address was a valid one, that the To address is myphonenumber@mms.att.net ... and still get:

3/29/10 1:30:49 PM Simon[1049] Recipient not accepted by server:
550 5.7.1 <9999999999@mms.att.net>: Relay access denied

I'm happy to help debug this if there's anything else I can do on my end... (I'm a software engineer by trade also), so please let me know how I can help!

Thanks,
Matt

David Sinclair's picture

Re: SMS Notifier / Recipient not accepted

There are couple of hidden preferences for the Email plugin that might help.

Firstly, enter "defaults write com.dejal.simon2 EmailDebugMode YES" in Terminal to add additional Console logging. Secondly, there's a preference to use the recipient's SMTP server instead of the sender's, via "defaults write com.dejal.simon2 EmailUseRecipientServer YES".

Try those, and hopefully we can figure out what is happening.

Re: SMS Notifier / Recipient not accepted

Aha, so changing the SMTP server to the recipient's server did work --- the notification went through.

Taking a look at the logs when I use one of my personal email addresses makes it look like AT&T doesn't want to relay from a pool of SMTP servers. One of my accounts is a .mac account, and I see things like (addresses changed to protect the innocent) :

3/29/10 4:47:23 PM Simon[3445] Email: Looking up domain for address <9999999999@mms.att.net>
3/29/10 4:47:23 PM Simon[3445] Email: Found servers: (
"smtp-mx002.mac.com.",
"smtp-mx001.mac.com.",
"smtp-mx005.mac.com.",
"smtp-mx006.mac.com.",
"smtp-mx003.mac.com.",
"smtp-mx004.mac.com."
)
3/29/10 4:47:23 PM Simon[3445] Email: _connectToServer: smtp-mx002.mac.com. onPort: 25
3/29/10 4:47:24 PM Simon[3445] Email: <- 220 smtpin124.mac.com -- Server ESMTP (Sun Java(tm) System Messaging Server 7u3-14.01 64bit (built Dec 27 2009))
3/29/10 4:47:24 PM Simon[3445] Email: -> HELO myMachine.local
3/29/10 4:47:24 PM Simon[3445] Email: <- 250 smtpin124.mac.com OK, [173.161.76.173].
3/29/10 4:47:24 PM Simon[3445] Email: writeEnvelopeTo: 9999999999@mms.att.net from: my.address@mac.com; -> MAIL FROM:
3/29/10 4:47:24 PM Simon[3445] Email: <- 250 2.5.0 Address Ok.
3/29/10 4:47:24 PM Simon[3445] Email: -> RCPT TO:<9999999999@mms.att.net>
3/29/10 4:47:24 PM Simon[3445] Email: <- 550 5.7.1 Relaying not allowed: 9999999999@mms.att.net
3/29/10 4:47:24 PM Simon[3445] Recipient not accepted by server:
550 5.7.1 Relaying not allowed: 9999999999@mms.att.net

The same thing happens if I use my corporate email, which is hosted by another email provider. That doesn't surprise me, however, because the domain part of my email address in no way relates to the SMTP server name.

Not sure there's anything to be done about this - looks like server rules. But thanks a ton for the workaround... Maybe a checkbox in the email plugin next time around?

Thanks!
Matt

David Sinclair's picture

Re: SMS Notifier / Recipient not accepted

Thanks for trying that. I'm glad you got it working via that hidden preference.

Yes, perhaps I need to expose that preference via a checkbox in the UI. Or maybe have the plugin automatically try reversing the connection if the initial attempt fails.

It seems strange to me that it works when talking to a third-party SMTP server rather than your own one, but there it is. Perhaps someone who is more expert at SMTP servers could explain why that might be?

Re: SMS Notifier / Recipient not accepted

Hmm, from digging around a little, it seems like using authentication is the solution here.

Relaying not allowed means that the SMTP server won't allow an unauthenticated user to send e-mail via its SMTP service.

Once I added in my credentials and specified the SMTP server explicitly using the e-mail notifier, everything was OK.

Perhaps we could convince Daniel to expose these options through the SMS plugin too?

Thanks for all the help David!
Matt

David Sinclair's picture

Re: SMS Notifier / Recipient not accepted

Ah yes, I should have thought of that. Yes, some (perhaps most) mail servers do require authentication.

I think the best option would be to move the mail transport options into a preference pane, so it can be shared by both the Email and SMS plugins.