Simon icon Simon
Flexible server monitoring

Introducing Simon 5!

Simon version 5 is now available. It is a massive update, introducing a much-requested feature: syncing the Simon data between multiple Macs, plus a Simon Status service, a Link Checker filter, improved Find filter, iMessage and Speak Error notifiers, a new app icon, and much more.

Important: please note that Simon 5 requires a minimum of macOS 10.12 (Sierra), and is a paid upgrade from Simon 4. Purchasers since September 1, 2020 automatically get a version 5 license (that also works in previous versions).

Read the Simon What's New page for details.

Why does "hiding" it on system startup not work?!?

I've got Simon added to the Startup items on my 10.6.7 system (System Preferences). I've checked the "hide" box so that I don't see its window (it runs in "background"). But it doesn't work - when the system starts, I still see the Simon window and it's in the dock. Why doesn't it obey the "hide" box?

David Sinclair's picture

Re: Why does "hiding" it on system startup not work?!?

Simon has a preference to hide the Monitor window when it isn't frontmost. Try enabling that.

The hide option in Startup Items doesn't hide the Dock icon, though.

I do have plans to split Simon up into separate apps, which will enable running Simon without it appearing in the Dock.

Re: Why does "hiding" it on system startup not work?!?

Thanks for the reply but i'm not sure its answered my question.

In Simon > Preferences... I have the "Automatically hide the Monitor window" set
In Dock > Simon > Options I have "Open at login" set
in System Preferences > Accounts > Administrator > Login Items > Simon I have the "Hide" Option ticked.

In response to the previous poster, each time the Mac is restarted (I run the 10.6 server version) the settings do not (like other software) hide the applications windows so that it will launch (spotlight under the respective Dock icon) but does not bring the Simon Monitor to the foreground, rather it automatically "Hide"s it. I have to select the Simon app and then "Hide" manually.

The "Automatically hide the Monitor window" (reading the Simon Help) setting hides the application from view when not selected at the foreground. This is not the same as the "Hide" setting in the System preferences to hide all newly launched apps upon automatic launch of an app.

Is this a bug? I'm running 3.0.2. Not tried under 3.1 as I'm not a keen beta tester (too many other things to do).

David Sinclair's picture

Re: Why does "hiding" it on system startup not work?!?

Simon's "Automatically hide the Monitor window" option hides the window when Simon isn't the frontmost app. That shouldn't interfere with the Login Item's Hide option.

When Simon is launched via Login Items, if Simon is the last app launched, it might remain active, and thus the Monitor window would appear. Though I would expect Login Items' Hide option to prevent Simon from becoming active.

I haven't tried that combo recently; there may be some improvement needed. I'll make a note to investigate.

Re: Why does "hiding" it on system startup not work?!?

Thank you for responding.

I had a quick look, on my system Simon is not the last app to load, its around 10 out of 20 or so... Although it still remains active until I click on another app after startup has completed (then it goes away).