Simon icon Simon
Flexible server monitoring

Please enter a valid URL

I'm getting "Please enter a valid URL" error when I try to save an edit to a test, but the URL works. Any ideas? Thanks

David Sinclair's picture

Re: Please enter a valid URL

I haven't experienced (or heard of) that. Is there something unusual about the URL? Does it happen always, or only for some tests, or only sometimes? Notice any patterns?

Re: Please enter a valid URL

You may already have the answer to this by this time but others may run into this same scenario.

1. Click '+ New' icon top left (Add a new site to test) or from drop down menu: File > New Test
2. New Window opens, Select 'Service' in top bar, under 'URL' enter full URL i.e. 'http://www.yourdomain.com'
3. Back to top bar and click 'Summary', then 'Name', Fill in whatever url reference you like preferably your truncated domain i.e. 'your domain.com'.
4. Click 'OK' and you are done.

Re: Please enter a valid URL

orlandojoe, thanks for the suggestion, but that doesn't help. If I follow the steps for creating a new test from scratch, I still get "Please enter a valid URL". I am trying to edit a test that has worked for a long time. I know the URL is "valid", whatever that means, because I can paste the URL into any browser and it works fine.

David Sinclair's picture

Re: Please enter a valid URL

Discussion moved to email....

David Sinclair's picture

Re: Please enter a valid URL

Followup for anyone interested: Richard resolved this issue by copying the URL to Safari then copying back into Simon. Which makes me think there was a control character (e.g. linefeed or tab) in the URL.

So I've made a note to filter those out in a future release.