Simon icon Simon
Flexible server monitoring

Can't detect changes

I'm trying to detect any change in a web page, to detect malware infection. I created a web http service for the page in question, and a filter for any change. Then I tested it by adding a period . character at the end of the web page and uploading it, but Simon doesn't detect any changes (last change: never). Of course I did some scans before and after the change in the web page. Am I doing it wrong?

David Sinclair's picture

Re: Can't detect changes

The usual cause of issues like this is that Simon doesn't detect changes for the first check after editing to test, to avoid falsely reporting a change when you alter the filter or other settings.

So try checking the test again a couple of times, without editing it, and see if that helps.

You could also look at the Activity log to see if that provides any clues. Email me a screenshot if you want me to take a look.

Another thing to try is to quit and re-launch Simon, in case it got into a weird state. Kinda like the old tech support adage of "when in doubt, reboot".

Re: Can't detect changes

The activity log does have some green triangles, which I assume indicate changes. However, the main screen says "Last Change: never" and the Changes tab shows nothing. But now I made a change and re-checked and the main screen and Changes tabs do show something now. So maybe there's a bug/feature whereby changes don't report on the main screen and changes tabs unless the activity log has been viewed first?

David Sinclair's picture

Re: Can't detect changes

I'm glad it's working properly now.

It's possible there could be a bug with refreshing some of the logs; I'll investigate that.