Simon icon Simon
Flexible server monitoring

Strange Email Issues using purchased project.

Originally I picked up a copy of the Simon (free) on the mac app store. All worked as I expected. So I then purchased a copy from the website (gold). Now after removing the app store copy and installing the purchased copy email alerts refuse to function. I use apple mail as the default but have also used the transport options. All fail. I see the helper app startup in the task bar for a time but then it goes away. What I see in the console log is attached to this message. Any suggestions would be appreciated, since, without the email alerts this does me little good.

Regards

AttachmentSize
preview.png169.15 KB
picture.png342.76 KB
editing.png79.96 KB
David Sinclair's picture

Re: Strange Email Issues using purchased project.

The log seems to suggest that it is expecting a CC item that is missing. I'm not sure why that'd be, but the workaround is probably to enter some address in the CC field.

I'll see if I can fix this for the next release.

Re: Strange Email Issues using purchased project.

I attached a 2nd picture. No joy. Next suggestion?

Re: Strange Email Issues using purchased project.

3rd file is attached. email alert/notifier sits there saying "editing" for about 5 minutes but will, normally, finally go away. I have had to force quit simon at least once to get it to stop being in the edit state and freezing the software up.

David Sinclair's picture

Re: Strange Email Issues using purchased project.

In your second picture it is missing a Subject. You definitely need one of those.

Re your third picture, did you click OK in the Edit Notifier window? It'll stay in "editing" state while the editor window is still open.

Though conceivably the exception could be interfering with that, so once you enter the required values, that problem should resolve itself.

Re: Strange Email Issues using purchased project.

The subject is at default "Simon says....etc..." Yes I hit OK and it just sits there, it will, in time, go away and say available. I have had "some" luck putting in a transport server manually but the results are inconsistent. Sigh.

Re: Strange Email Issues using purchased project.

In addition I am finding it almost impossible to get exchange 2010 to work with the notifier; the logs show it simply gets stuck at "Now starting SSL" and won't get past that. As I have said I have had some luck using a more "basic" type of mail server but even that hasn't been consistent as of this writing. I am going to try to uninstall all of simon and reinstall it. Perhaps that will buy me something.