Time Out icon Time Out
You deserve a break

Timers continue after break ends.

If I have a 10 minute break scheduled and walk away for 20 minutes. The timers will be 10 minutes into the next break. Everything is default, Event Monitor is selected and security features are allowed.

If I trial run When this break is due: Wait for a natural break. This break starts after the 15 seconds. However the timers continue going.

It's frustrating and leads to a lack of trust when I sit down and have the break pop up in the next 5 minutes.

Is this intended?

Update: natural breaks don't seem to start when Time Out is the front most screen.

David Sinclair's picture

Re: Timers continue after break ends.

You can look in the Console log to see what the scheduler is doing.

The timers are continually running, except when in a natural break (idle).

Waiting for a natural break when due will only wait for a short time (up to a minute as I recall), to avoid interrupting you -- but starts anyway if you ignore it.

Re: Timers continue after break ends.

So there does seem to be a problem, at least on my end.

What works:

1. Leave Timeout settings window open (doesn't need to be on top).
2. Leave desk for break
3. Timeout will naturally fall into natural break after the break window disappears.
4. Come back to desk and timers are paused.

What doesn't work:

1. Minimize Timeout settings window.
2. Leave desk for break, Timeout will repeatedly run through break timers.
3. Timeout won't fall into natural breaks after break window disappears.

This will it least let me get it to behave correctly by leaving the settings window open.

David Sinclair's picture

Re: Timers continue after break ends.

Do you have the Dock icon shown or hidden?

Re: Timers continue after break ends.

The dock icon is shown.

David Sinclair's picture

Re: Timers continue after break ends.

I think I've fixed this for 2.0.2.

Re: Timers continue after break ends.

I'm having a similar problem with 2.0.2. If the preferences screen isn't foreground, and Google Chrome is, the break screen will pop up even if I should be in a natural break. This is problematic with streaming web content (e.g. Amazon.)

David Sinclair's picture

Re: Timers continue after break ends.

Hmm. I'm not sure why that might be; I thought I fixed a possible cause.

You could try hiding the Dock icon, which seems to help. Or the above workaround of leaving the preferences window open.

Re: Timers continue after break ends.

Just having the preferences open wasn't enough; it had to be foreground.
Hiding the dock icon does seem to solve the problem. Thank you!

David Sinclair's picture

Re: Timers continue after break ends.

Hmm, I wonder if I need to go back to my original design of separating the scheduler and preferences. The first few alphas of 2.0 had them as separate processes; a background-only scheduler helper, and a main app just for the preferences. But I merged them to simplify things, and to work around an OS bug where a helper outside the app bundle can get launched.