Time Out icon Time Out
You deserve a break

Breaks not resetting

My breaks are not resetting when my screen is locked.

I have already added Time Out to the accesibility settings as instructed, and the Natural Break Detection Method is set to Event Monitor.

I would like to know how to solve this i.e. I want the natural break detection to work even with Lock screen, or a lid close event.

Technical Details -
OS: El Capitan
Timout Version: 2.0.2 (2022)

David Sinclair's picture

Re: Breaks not resetting

Try turning on scheduler logging in the Advanced preferences, then look in the Console log after waking; that should show why it isn't resetting.

Re: Breaks not resetting

fyi, it's not working for me either.

I close my Macbook's laptop lid, come back 2 hours later, and Time Out starts counting down from 10 minutes instead of 1 hour...

I'll check the log next time.

Time Out Version 2.0.2 (2022) - App Store

Re: Breaks not resetting

I closed my Macbook lid at 17:37
I re-opend my Macbook lid at 20:30 (and also disconnected the power)

Logs: https://gist.github.com/anonymous/3346a800a9fdb3b65d64aa5057df1c37

Obviously, when the lid is closed i can not be *using* my Macbook - even though my Macbook may be running tasks in the background like update checking, mail fetching, etc.

David Sinclair's picture

Re: Breaks not resetting

Thanks for the log. It does show that it detected the sleep, and treated it as idle, but I agree it should do a better job of adjusting the schedule, perhaps resetting when idle for longer than the frequency or duration. I'll see what I can do for the next release.

Re: Breaks not resetting

Thanks for your reply;

i'm not sure i fully understand. I had been away from my Macbook for almost 3 hours, and then when i returned Time Out said i have to take a break in 8 minutes.

Shouldn't TimeOut have (100%) counted backwards in those 3 hours - and therefore start with a new 60 minute countdown?

David Sinclair's picture

Re: Breaks not resetting

Yes, if you have it set to count backwards on idle, as is the default.

You can turn on scheduler logging in the Advanced preferences, then look in the Console log the next time this occurs, to see what happened.

Re: Breaks not resetting

Yes, it's set to "count backwards on idle", so apparently this didn't work. I already provided the link to the log in my comment above.

David Sinclair's picture

Re: Breaks not resetting

Oh yeah, sorry. I do plan to improve this for 2.1; I have some notes based on this discussion.

Re: Breaks not resetting

ok great, thanks :)