Simon icon Simon
Flexible server monitoring

Introducing Simon 5!

Simon version 5 is now available. It is a massive update, introducing a much-requested feature: syncing the Simon data between multiple Macs, plus a Simon Status service, a Link Checker filter, improved Find filter, iMessage and Speak Error notifiers, a new app icon, and much more.

Important: please note that Simon 5 requires a minimum of macOS 10.12 (Sierra), and is a paid upgrade from Simon 4. Purchasers since September 1, 2020 automatically get a version 5 license (that also works in previous versions).

Read the Simon What's New page for details.

No Notifiy Now... No nuthin

I'm having trouble troubleshooting an email notifier that uses SMTP transport. I have the Notifier forms filled out correctly (Identical to my gmail account in Mail App )

When I hit the "Notifiy Now" with the Notifier in question selected, Nothing happens. Nada. The "Notifiy Now" briefly changes to a darker color indicated it was clicked, but nothing happens. No email is sent / recieved. No error message.

(I'm doing this via VNC so I can't hear any alert sounds... )

I can send mail using SMTP using the mail app on the same account/ and port# on the same machine, same settings. Using the "automatic" setting on transport froze Simon twice with the "Notifiy Now" button in the darkened 'click' state

How can I figure out what is happening (or not happening ). Are 'Notify Now" attempts logged somewhere?



Quick Test to see if forum

Quick Test to see if forum replies are emailed to me... Cheers

David Sinclair's picture

Re: No Notifiy Now... No nuthin

You may be able to see some information logged to the Console.

The Email notifier is certainly the hardest to configure; I need to improve this, somehow.

Another customer recently had difficulty with Gmail, but I was able to get it to work, so it isn't an inherent problem. I recommend double-checking your configuration, both in the Edit Notifier window (make sure all fields are filled in) and the transport options window.

As for Automatic freezing Simon, that's new to me. I'd be interested in any Console log entries and/or Sample reports on that.

DaveR's picture

Notify Now e-mail issue

I was seeing the same issue with the Notify Now button not sending an e-mail notification. I tried two different e-mail accounts - one (SSL) and one (non-SSL) - with different combinations of settings to no effect. Happened in Simon 2.4.2 and earlier versions.

I then simply duplicated the e-mail notifier (while set for the non-SSL account) and without making any changes the new notifier worked with Notify Now. I then tried Notify Now with the original notifier, again without making any changes, and it worked too.

Next I switched the settings back to the SSL account. Stopped working again. Switched back to the non-SSL account. Still not working. Stopped and started Simon and it worked again (with the non-SSL account).

From the console log when things aren't working:

# Note - testing with SSL account
2008-09-24 06:09:07.006 Simon[331] Pantomime: Connected!
2008-09-24 06:09:07.006 Simon[331] Now starting SSL...
2008-09-24 06:12:17.677 Simon[331] Pantomime: Connected!
2008-09-24 06:12:17.678 Simon[331] Now starting SSL...
# Note - switched to non-SSL account
2008-09-24 06:15:05.126 Simon[331] Pantomime: Connected!
# Note - after duplicating notifier with non-SSL account
2008-09-24 06:28:24.987 Simon[331] Pantomime: Connected!
2008-09-24 06:28:25.041 Simon[331] Pantomime: Available authentication mechanisms: (PLAIN, LOGIN)
2008-09-24 06:28:25.150 Simon[331] Pantomime: Authentication completed! Sending the message...
2008-09-24 06:28:25.413 Simon[331] Pantomime: Sent!
Closing the connection.

So, testing and failing with the SSL account stopped future tests from working until either the program was restarted or a new notifier was created.

David Sinclair's picture

Re: Notify Now e-mail issue

Thanks for investigating that. Looks like the third-party framework I use for non-Automatic connections gets confused if changing the configuration, until re-launch. Good to know.

Any progress on this issue?

I was just checking any updates... and I thought I'd stop by and see if any progress is being made on the email notifier issue.

I'm not sure if the email notifiers stopped working because of an update or due to a Comcast port 25 block... leading me to configure with SSL ports.

Right now Simon is useless due to the SSL email bug. Please advice.

BTW is there any way to subscribe to threads on this forum?

David Sinclair's picture

Re: Any progress on this issue?

Unfortunately not; I haven't heard back from the framework author yet. In the meantime, you should be able to use the Automatic transport, if you can get non-SSL access enabled on your mail server, since that doesn't use the framework. It communicates directly with your SMTP server.

Subscriptions to threads isn't supported currently, though is something I might add in the future. In the meantime, you can always use Simon to watch this page. :)