Simon icon Simon
Flexible server monitoring

Introducing Simon 5!

Simon version 5 is now available. It is a massive update, introducing a much-requested feature: syncing the Simon data between multiple Macs, plus a Simon Status service, a Link Checker filter, improved Find filter, iMessage and Speak Error notifiers, a new app icon, and much more.

Important: please note that Simon 5 requires a minimum of macOS 10.12 (Sierra), and is a paid upgrade from Simon 4. Purchasers since September 1, 2020 automatically get a version 5 license (that also works in previous versions).

Read the Simon What's New page for details.

App Store version of Growl not Registering Simon

Has anyone had any luck using the App Store version of Growl for getting notifications? I don't even have Simon registering in my Growl list of applications.

David Sinclair's picture

Re: App Store version of Growl not Registering Simon

Simon should work fine with the App Store edition of Growl. I'm using this combo successfully.

Maybe you need to remove the old prefpane edition of Growl?

Re: App Store version of Growl not Registering Simon

Thanks for your reply. I never had the old pref pane version on this mac, so that's likely not the issue.

I ran the Growl Framework Detective and found that Simon Free 3.4 from the app store is running the 1.2.3 Growl framework instead of the 1.3.3 framework. I wonder if that could be the issue?

David Sinclair's picture

Re: App Store version of Growl not Registering Simon

Growl 1.2.3 was the first to support the new Growl app. It is the newest version that supports 10.5 and PPC, which is required for Simon, since it still supports those (for now).

I'll probably drop 10.5 and PPC support around the end of 2012, or early 2013, so I'll be able to upgrade the Growl framework at that time.

In the meantime, as I said, I am successfully using Simon 3.4 with the latest Growl app. So I'm not sure what the issue is. Could perhaps be something different in Simon Free, though I wouldn't expect so — it's the same code as the standard edition. You could try the standard edition to see if works better for you, though.