Simon icon Simon
Flexible server monitoring

Introducing Simon 5!

Simon version 5 is now available. It is a massive update, introducing a much-requested feature: syncing the Simon data between multiple Macs, plus a Simon Status service, a Link Checker filter, improved Find filter, iMessage and Speak Error notifiers, a new app icon, and much more.

Important: please note that Simon 5 requires a minimum of macOS 10.12 (Sierra), and is a paid upgrade from Simon 4. Purchasers since September 1, 2020 automatically get a version 5 license (that also works in previous versions).

Read the Simon What's New page for details.

Simon doesn't start

I've just upgraded to Mountain Lion.
I downloaded latest Simon (v3.4) from this website.

As soon as I run I get the following error msg:
"" is damaged and can't be opened. You should move it to the Trash.

"Simon Free" from the App Store works, but I want to add my existing license and the free version doesn't support this.

What's up?

David Sinclair's picture

Re: Simon doesn't start

Simon doesn't yet support Mountain Lion's Gatekeeper feature, which is what is presenting that alert.

You can bypass it by selecting the Simon icon in the Finder and right-clicking on it (or Ctrl-click) and choose Open from the contextual menu, then confirm that you want to open it.

You only need to do this once.

You'll find similar behavior with other apps built before Mountain Lion was introduced; you can allow launching any new apps by changing your Security system preferences.

Simon 3.5 will include Gatekeeper support; it'll be out in a few weeks time.

Re: Simon doesn't start

Thanks for the prompt reply, but that doesn't fix it, and strangely Simon 2.5.7 does run (also freshly downloaded from your homepage).

This error message I'm experiencing differs to those I've seen for other apps (which dont support Gatekeeper) in Mountain Lion. The Gatekeeper message you refer to is different (..."can't be opened because it is from an in identified developer").

However, the particular error message I'm seeing is stating that is damaged (I've downloaded it multiple times in Safari & Chrome just in case it was a corrupt download).

Re: Simon doesn't start

Ok - I've found out what the problem is...

If I extract the using the built in native "Archive Utility" that comes with the OS: extacts a corrupt file!
If I instead extract it using Stuffit Expander: it works!

I guess this means there's an incompatibility with the zip format with the native archive extractor utility.

Re: Simon doesn't start

humm... If I run the following command on the "Archive Utility" extracted version that appeared to be corrupt, it corrects it and runs successfully:

xattr -d

David Sinclair's picture

Re: Simon doesn't start

Yeah, the error is unusual and misleading... but it does seem related to Gatekeeper, as if you change the Security system preferences to "Anywhere", Simon will launch without issue.

I just need to get Simon 3.5 finished. Simon is such a complex app, updating it for Mountain Lion is quite a lot of work.